Partial Outage in work of Countdown Timer Service
Incident Report for Stripo
Resolved
This incident has been resolved.
Posted Mar 30, 2020 - 05:57 UTC
Investigating
There might be issues while viewing, changing or creating new Countdown Timer blocks inside the editor. Already created timers in your email campaigns should work as expected.

Time (UTC) : 2020-03-30T05:55:21
Posted Mar 30, 2020 - 05:55 UTC
This incident affected: Online Web Editor (Countdown Timer Service).