The issue with increased response times in the Plugin API Gateway has been resolved, and plugin initialization is now operating normally.
Root cause: During a scheduled AWS infrastructure update to apply patches, which was expected to proceed without downtime and therefore was not communicated in advance, an unfortunate misconfiguration occurred, which we have already identified and fixed. Some pods were terminated before new ones were fully ready, leading to a significant accumulation of requests in the queue. Instead of being processed gradually, a large batch of queued requests was handled simultaneously, which exhausted available database connections and caused delays in processing new incoming requests.
We are optimizing our deployment and scaling procedures to prevent similar situations in the future.
Posted Apr 21, 2026 - 13:57 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 21, 2026 - 13:51 UTC
Investigating
We are currently experiencing increased response times in the Plugin API Gateway, which is impacting the speed and ability to initialize new plugins.
Posted Apr 21, 2026 - 13:36 UTC
This incident affected: Stripo Plugin (API Gateway Service (plugin)).