Plugin Initialization Issue
Incident Report for Stripo
Resolved
Our DevOps team has updated the configuration to ensure all necessary headers are properly whitelisted. The plugin can now be initialized without issues.

The plugin is now fully functional, and users should no longer experience any initialization problems.

We apologize for any inconvenience this incident may have caused and appreciate your patience while we worked to resolve it.

Thank you for your understanding and continued support.
Posted Jul 22, 2024 - 12:50 UTC
Identified
Our team has identified the root cause of the plugin initialization issue. During the maintenance performed yesterday (details available here), we migrated our infrastructure from HTTP/1.1 to HTTP/2. Since this migration, we have received customer reports indicating that certain headers used in their requests are blocked.

Our DevOps team has been working to add specific header fields to the whitelist as these requests come in. It appears there is a configuration issue within this process. We are continuing to work on resolving this configuration issue to ensure all necessary headers are allowed and the plugin can be initialized successfully.
Posted Jul 22, 2024 - 12:41 UTC
Investigating
We are currently experiencing an issue with our plugin infrastructure. Since 11:55 PM (UTC time), users have been unable to initialize the plugin due to a Cross-Origin Resource Sharing (CORS) error.

This issue affects all users attempting to use the plugin, rendering it non-functional at this time.
Posted Jul 22, 2024 - 12:33 UTC
This incident affected: Stripo Plugin (API Gateway Service (plugin)).