Partial Outage in work of Stripo Account Backend part
Incident Report for Stripo
Postmortem

Incident Details

At approximately 14:49, our monitoring systems detected a significant spike in database loads. This increase in load caused delays in database queries and resulted in a slowdown of our services. Our engineering team was alerted immediately and began investigating the root cause of the issue.

By 15:24, we were able to identify the source of the increased load and implemented measures to mitigate it. Normal service was restored, and the database load returned to acceptable levels.

Impact

During the service interruption, users may have experienced:

  • Delays in email template loading
  • Slow response times when accessing the Stripo.email platform
  • Temporary inability to save or send emails

Resolution

Our engineering team took the following actions to resolve the incident:

  1. Identified the source of the increased database load.
  2. Implemented load balancing measures to distribute the database queries more efficiently.
  3. Optimized specific database queries to reduce processing time.

Preventive Measures

To prevent similar incidents in the future, we are taking the following steps:

  1. Enhancing our monitoring systems to detect and alert us to abnormal load patterns more quickly.
  2. Conducting a thorough review of our database infrastructure to identify and address potential bottlenecks.
  3. Implementing additional load balancing solutions to ensure better distribution of database queries.

We apologize for any inconvenience this incident may have caused and appreciate your patience and understanding as we worked to resolve the issue. Our team is committed to ensuring the reliability and performance of our services.

Posted Jun 27, 2024 - 16:35 UTC

Resolved
On June 27, 2024, between 14:49 and 15:24 UTC, Stripo service experienced a service interruption. This interruption was due to an unexpected increase in the loads on our database.
Posted Jun 27, 2024 - 15:24 UTC