Issues with image and document uploads in Stripo Plugin

Incident Report for Stripo

Postmortem

Root cause
The incident was caused by an issue during a planned rotation of the access key used for the primary image storage service.

The new key was not correctly propagated to one of the services responsible for handling storage operations. As a result, requests from that service could not authenticate with the storage, causing image and document upload operations to fail.

We also identified a gap in our internal documentation related to the key rotation procedure, which contributed to the incident.

Resolution
The storage credentials were corrected and successfully propagated to all affected services. Once the configuration was updated, upload functionality returned to normal.

We have also updated the relevant internal documentation to include the previously missing configuration step.

Preventive actions
We are reviewing the credential rotation procedure to ensure that all dependent services are covered and that configuration changes are validated before and after rotation. We are also improving our internal documentation and verification procedures to reduce the risk of similar incidents in the future.

We apologize for the disruption and appreciate your patience while our team worked to resolve the issue.

Posted Sep 18, 2026 - 15:52 UTC

Resolved

This incident has been resolved.
Posted Sep 18, 2026 - 14:56 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 18, 2026 - 14:54 UTC

Investigating

We are currently experiencing an issue affecting some Stripo Plugin functionality. Some users may be unable to upload images or documents or update storage credentials.

Our team is investigating the issue and working to restore normal operation as quickly as possible.

Start time: Sep 18, 13:41 UTC
Posted Sep 18, 2026 - 13:41 UTC
This incident affected: Stripo Plugin (Documents Service (plugin)).