Partial Outage in work of Image Storage

Incident Report for Stripo

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 12:08 UTC

Update

We are currently experiencing a global outage caused by Cloudflare. Due to this issue, all images uploaded by users to Stripo Storage are temporarily unavailable and cannot be retrieved or displayed.

Our team is actively monitoring the situation on Cloudflare’s official status page https://www.cloudflarestatus.com/ and, in parallel, working on switching traffic to a backup channel to restore image availability as soon as possible.

We will provide updates as we learn more. Thank you for your patience.
Posted Nov 18, 2025 - 12:04 UTC

Investigating

There might be issues in accessing images from the Stripo storage which are used inside created email templates.

Time (UTC) : 2025-11-18T11:59:01
Posted Nov 18, 2025 - 11:59 UTC
This incident affected: Image Storage.