Partial Outage in work of Guid Service
Incident Report for Stripo
Resolved
This incident has been resolved.
Posted Feb 17, 2020 - 12:10 UTC
Investigating
There might be an issue related to creating new email templates and or uploading new images to Image Library.

Time (UTC) : 2020-02-17T12:08:00
Posted Feb 17, 2020 - 12:08 UTC
This incident affected: Online Web Editor (Guid Service).