Partial Outage in work of Billing Service
Incident Report for Stripo
Resolved
This incident has been resolved.
Posted Feb 17, 2020 - 13:32 UTC
Investigating
There might be issues while changing the pricing plans and making new charges.

Time (UTC) : 2020-02-17T13:31:48
Posted Feb 17, 2020 - 13:32 UTC
This incident affected: Online Web Editor (Billing Service).