Partial Outage in work of Billing Service
Incident Report for Stripo
Resolved
This incident has been resolved.
Posted Jan 06, 2021 - 08:37 UTC
Investigating
There might be issues while changing the pricing plans and making new charges.

Time (UTC) : 2021-01-06T08:36:48
Posted Jan 06, 2021 - 08:36 UTC
This incident affected: Online Web Editor (Billing Service).